I suggest you ...

not load the OpenLayers map on the homepage by default

perhaps this can be a snapshot image before trying to load the client everytime someone visits the home page. Click on the snapshot would enable the client or something like that..

1 vote
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Al shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Al commented  ·   ·  Flag as inappropriate

    it takes too long for the map client to load on slower connections.

Feedback and Knowledge Base